$re = '/^-.+?(.[\-\s]+[^\s]+)+/';
$str = '-a -m --ammend "some -test text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);