re = /^#[^#].+$([\s\S]+?)(^#[^#].+)/m
str = '# fkl;hjl;g
fhfj
## fhkljkljkl;;
#fgjklgf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end