re = /0|1|2|3|4|5|6|7|8|9/m
str = '1234
adsfad
adafd3334
asd fasdf12 34
شسيبشيسب
شيسبش سيبشسيب232323111111111111
123
شسيبشسيبشسيب
١١إحدى عشر
١١'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end