import Foundation
let pattern = #"\S+\@\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
From: Avanan
Sent: Thursday, December 5, 2024 2:39 PM
To: Support
Subject: Security event detected
Hello,
Please look at the details of the following anomaly event.
Details:
Dana@acme.com performed geo-suspicious events: logged in from United States (216.221.27.67) and after 1 minute logged in from United States (173.160.110.50)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}