import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"(.*)\" (.*), (.*)";
final String string = "Description\n"
+ "\"Mulligan\" neutered male, Brindle Bullmastiff\n"
+ "\"Tiny\" male, tan and white Boxer mix\n"
+ "\"Charlie\" neutered male, black and white Labrador Retriever mix \n"
+ "\"Nala\" spayed female, white and brown brindle Pit Bull mix\n"
+ "\"Lexie\" female, white and black Pit Bull \n"
+ "\"Holly\" Spayed female, white Labrador/Pitbull mix\n"
+ "\"Lincoln\" male, fawn and white Pit Bull Terrier\n"
+ "\"Sparkles\" spayed female, Brindle Plott Hound mix\n"
+ "\"Missy\" Spayed Female, red/white Pitbull mix\n"
+ "\"Rita\" female, brown Australian Shepherd \n"
+ "\"Miles Davis\" female, gold/white Golden Retriever \n"
+ "\"Lacy\" spayed female, Labrador Retriever Mix\n"
+ "\"Clementine\" spayed female, black and white Austrailian Cattle dog\n"
+ "\"Coronel\" Male, Tan/Black German Shepherd mix\n"
+ "\"Lady Bug\" spayed female, white/black Pit bull/Jack Russell mix\n"
+ "\"Buddy\" male, blue brindle and white Pitbull mix\n"
+ "\"Boomer\" neutered brown Pit Bull Mix\n"
+ "\"Weezer\" female, Tan/Brown German Shepherd\n"
+ "\"Little Girl\" spayed female, brown brindle and white Bull Terrier\n"
+ "\"Diva\" intact female, tri-color Pit Bull\n"
+ "\"Jack\" neutered male, red/white Labrador Retriever mix \n"
+ "\"Salty\" male, brown and white Boxer\n"
+ "\"G\" male, brown Pit Bull/Boxer mix \n"
+ "\"Keely\" spayed female, Red Labrador Retriever mix\n"
+ "\"Tyson\" neutered male, German Shepherd\n"
+ "\"Tug\" male, brown merle and white Queensland Heeler mix\n"
+ "\"Shebba\" female, white Pit Bull mix \n"
+ "\"Blue\" male, blue Pit Bull mix\n"
+ "\"Pinky\" female, white Boxer mix\n"
+ "\"Ladybird\" Spayed female, yellow brindle and white Pit Bull mix\n"
+ "\"Dozer\" neutered male, white and red Rhodesian Ridgeback\n"
+ "\"Lahlo\" spayed female, tan Boxer mix\n"
+ "\"Maya\" spayed female, brown/white Pitbull mix\n"
+ "\"Cinnamon\" female, red and white Border Collie \n"
+ "\"Taz\" neutered male, brown brindle Boxer mix\n"
+ "\"Lily\" female, black and white Chihuahua\n"
+ "\"Abbo\" neutered male, white/brown Great Pyrenees mix \n"
+ "\"Milo\" neutered male, white/brown, German Short-haired Pointer\n"
+ "\"Lia\" spayed female, white/black Pit Bull/Jack Russell mix\n"
+ "\"Sissy\" female, tan and black German Shepherd\n"
+ "\"Nippy\" female, black and tan Shepherd mix\n"
+ "\"Ginger\" spayed female, red and white American Fox Terrier mix\n"
+ "\"Jonah\" female, brown and white Pit Bull mix\n"
+ "\"Diego\" neutered male, cream and white Great Pyrenees\n"
+ "\"June\" female, Brindle Pit Bull Terrier \n"
+ "\"Maia\" female, white/tan Pit Bull mix\n"
+ "\"Iko\" neutered male, Brown Brindle Catahoula mix\n"
+ "\"Zues\" neutered male, blue and white Great Dane\n"
+ "\"Tank\" neutered, black/grey German Wire-haired Pointer \n"
+ "\"Bumpy\" neutered male, white and black Bull Terrier\n"
+ "\"Negro\" neutered male, black, tan and white Chihuahua mix\n"
+ "\"Lucy\" spayed female, brown brindle and white Boxer mix\n"
+ "\"Austin\" male, red merle Australian Shepherd\n"
+ "\"Aries\" spayed female, blue Cane Corso\n"
+ "\"Bella\" spayed female, Tan and White Pit Bull mix\n"
+ "\"Gucio\" male, black Giant Schnauzer\n"
+ "\"Kilo\" neutered male, red and white Pit Bull mix\n"
+ "\"Chuy\" spayed female, brown brindle and white Boxer mix\n"
+ "\"Flint\" neutered male, blue Blue Lacy mix\n"
+ "\"Sydney\" spayed female, Tricolor/Black Beagle \n"
+ "\"Sunny\" Neutered Male, Brown/Tan Shepherd mix\n"
+ "\"Lucky\" male, black and tri-colored Chihuahua\n"
+ "\"Cleo\" female, black Labrador Retriever mix ";
final String subst = "$1\\t$2\\t$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}