package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<photo=.+?>`)
var str = `The trip is wonderful.<photo=2-1-1601981-7-1.jpg><photo=2-1-1601981-5-2.jpg>We enjoyed it very much.<photo=2-1-1601981-5-2.jpg><photo=2-1-1601981-7-1.jpg>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}