$re = '/\b((?:Movement|mouvement) no\.|mouvement signés\.Numérotée|no|MVT|jewels #|Werk-Nr\.) (\d+)/mi';
$str = 'Longines. A very fine and rare stainless steel water-resistant chronograph wristwatch with black dial and original box\\nSigned Longines, retailed by Barth, Zurich, ref. 22127, movement no. 5770083, case no. 46, circa 1941\\nCal. 13 ZN nickel-finished lever movement, 17 jewels, the black dial with Arabic numerals, outer railway five minute divisions and tachymetre scale, two subsidiary dials indicating constant seconds and 30 minutes register, in large circular water-resistant-type case with flat bezel, downturned lugs, screw back, two round chronograph buttons in the band, case and movement signed by maker, dial signed by maker and retailer\\n37 mm. diam.
MONTRE BRACELET D\'HOMME CHRONOGRAPHE EN OR, PAR LONGINES\\n\\nDe forme ronde, le cadran noir à chiffres arabes, cadran auxiliaire pour les secondes à neuf heures et totalisateur de minutes à trois heures, mouvement mécanique 13 Z N, vers 1960, poids brut: 44.49 gr., monture en or jaune 18K (750)\\n\\nCadran Longines, mouvement no. 3872616, fond de boîte no. 5872616\\nVeuillez noter que les bracelets de montre pouvant être en cuirs exotiques provenant d\'espèces protégées, tels le crocodile, ils ne sont pas vendus avec les montre même s\'ils sont exposés avec celles-ci. Christie\'s devra retirer et conserver ces bracelets avant leur collecte par les acheteur';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);