re = /^[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}$/m
str = '12345678-90ab-cdef-1234-567890ABCDEF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end