import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)\\b(?:https?:\\/\\/)?(?:w{3}\\.)?youtu(?:be)?\\.(?:com|be)\\/(?:(?:\\??v=?i?=?\\/?)|watch\\?vi?=|watch\\?.*?&v=|embed\\/|)([A-Z0-9_-]{11})";
final String string = "http://youtube.com/v/tFad5gHoBjY\n"
+ "https://youtube.com/vi/tFad5gHoBjY\n"
+ "http://www.youtube.com/?v=tFad5gHoBjY\n"
+ "http://www.youtube.com/?vi=tFad5gHoBjY\n"
+ "https://www.youtube.com/watch?v=tFad5gHoBjY\n"
+ "youtube.com/watch?vi=tFad5gHoBjY\n"
+ "youtu.be/tFad5gHoBjY\n"
+ "http://youtu.be/qokEYBNWA_0?t=30m26s\n"
+ "youtube.com/v/7HCZvhRAk-M\n"
+ "youtube.com/vi/7HCZvhRAk-M\n"
+ "youtube.com/?v=7HCZvhRAk-M\n"
+ "youtube.com/?vi=7HCZvhRAk-M\n"
+ "youtube.com/watch?v=7HCZvhRAk-M\n"
+ "youtube.com/watch?vi=7HCZvhRAk-M\n"
+ "youtu.be/7HCZvhRAk-M\n"
+ "youtube.com/embed/7HCZvhRAk-M\n"
+ "http://youtube.com/v/7HCZvhRAk-M\n"
+ "http://www.youtube.com/v/7HCZvhRAk-M\n"
+ "https://www.youtube.com/v/7HCZvhRAk-M\n"
+ "youtube.com/watch?v=7HCZvhRAk-M&wtv=wtv\n"
+ "http://www.youtube.com/watch?dev=inprogress&v=7HCZvhRAk-M&feature=related\n"
+ "youtube.com/watch?v=7HCZvhRAk-M\n"
+ "http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}