re = /(?=[^\/]+$).+(?=\?)/m
str = 'https://servername.windows.net/virtual/folder/IwantToFindThisFileName.AnyExtension?Azurekey=SASKeyDetails'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end