re = /:(?:[^:\s]|::)*:/
str = ':any-non-whitespace:
:text1:sample2:
:@(1@#$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end