re = /(?<=\/)([^\/]*?)(?=\/|$)/m
str = 'первое вхождение / остальные / вхождения / в / строке'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end