import re
regex = re.compile(r"1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})")
test_str = "11234567890"
subst = "+1($1)-$2-$3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)