re = /(?ms)^(?!.*?^fruit (?!apple|banana|cherry))(?=.*?^fruit banana)(?=.*?^fruit cherry)(?=.*?^fruit apple).*$/m
str = 'fruit apple
some other config line
############
fruit banana
fruit cherry
other config 1
other config n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end