re = /(?<logdir>\/(?:[^\/]+\/)*)(?<date>(?:19|20)\d{2}(?:0?[1-9]|1[012])(?:0[1-9]|[12]\d|3[01]))\/job_(?<jobname>\w+)_\d+_(?<region>[^\W_]+)_log/m
str = '/home/app/abc/logs/20200817/job_DAILY_HR_REPORT_44414_USA_log
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end