re = /^(?!\d*(\d)\d*(?:(\d)\d*\1\d*\2|\1\d*(\d)\d*\3)|0)(?=\d*(\d).*\4)\d{10}$/m
str = '1134567890
2123456789
1234267890
1671812342
1934466892:6
1234@56789
3563893124
4412356789
2349780915
981651321182234556
1234567890
10000000000
02346ex789
0000%00000
0234567 894
8232527884
02325278847
02345678945
2323456789
8152228374
0234527834
8183746528
0435465768
3245657689
1223345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end