$re = '/^\w+_+\w+$/m';
$str = 'my_proper';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);