import re
regex = re.compile(r"DATE: (?P<date>[\s\S]+)\nSTAGE: (?P<stage>[\s\S]+)\nSCORE: (?P<score>[\s\S]+)\nNAME: (?P<name>[\s\S]+)\nHOBBY: (?P<hobby>[\s\S]+?)\n(?:AGE: )?(?P<age>[\s\S]*?)(\n)?NOTES:(?P<notes>[\s\S]+)", flags=re.MULTILINE)
test_str = ("DATE: 2/3/21 10:23:42 AM CST\n"
"STAGE: 1\n"
"SCORE: 2,321\n"
"NAME: Sally\n"
"HOBBY: Swimming\n"
"NOTES: But she doesn't like: sun, fish\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")