using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\(|\(.|\(..)([^\w\s])(?![^(]*\))";
string substitution = @"\\$1";
string input = @"Foo (.*) bar blla (.*) b*l?a$ && bla bla ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}