#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:\d{3}-| # area code without parentheses but with dash" & @CRLF & _
"\(\d{3}\)\ ) # -or- area code with parentheses and no dash" & @CRLF & _
"\d{3} # first 3 digits" & @CRLF & _
"- # second dash" & @CRLF & _
"\d{4} # last 4 digits"
Local $sString = "(415) 123-2342 and 415-905-1234 are the numbers."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")