package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{6}(\d{10})$`)
var str = `1234567890123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}