package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+?)=`)
var str = `41=26; 42=27,5; 43=28;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}