$re = '/(?: \| Vivaldi Forum|Vivaldi Desktop Browser)/m';
$str = 'Minor Update (2) for Vivaldi Desktop Browser 6.8 | Vivaldi Forum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);