re = /^([0-1]\d|2[0-4])\:[0-5]\d:[0-5]\d$/mi
str = 'afd26bsh377777777777777
192.168.4567.
.com@napier.co.uk
13:22:59
04:24:45
35:27:48
26:34:34
13:56:53
16:59:23
00:00:00:21:23:12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end