re = /^[^@]*<[a-zA-Z0-9!#$%&\'*+\/=?^_`{|}~-]+(?:\.[a-zA-Z0-9!#$%&\'*+\/=?^_`{|}~-]+)*@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?\.)+[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?>$/
str = '"attacker\\" -oQ/tmp/ -X/var/www/cache/phpcode.php some"@email.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end