import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9.\\n-]+|^-0*(?:1\\.0*[1-9]|[2-9]|1\\d+).*|(?!^)-";
final String string = "0\n"
+ "-1\n"
+ ".00000\n"
+ "-1.0000\n"
+ "-1.0\n"
+ "-1.0001\n"
+ "-2\n"
+ "-1.9\n"
+ "-400\n"
+ "1lllllllll\n"
+ "12\n"
+ "12.\n"
+ "1234.124\n"
+ "123.-234.234\n\n"
+ "-00001.0000\n"
+ "-00001.001\n"
+ "-00002";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}