$re = '/(?<!\d)(\.)/m';
$str = '.34
1.45
66+.33+22+.32
5+.22 5+0.22 5+.22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);