package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)end$`)
var str = `matches a string that ends with end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}