package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\s(?<cRegexGroupsName>.*?)$`)
var str = `RODRIGUEZ FERNANDEZ FRANCISCO JAVIER`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}