// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,3}%").unwrap();
let string = "Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libvlc$
Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 fonts-freefont-ttf$
40% [12 fonts-freefont-ttf 855 kB/4,140 kB 21%]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}