package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d{5}(-\d{4})?$)|(^[ABCEGHJKLMNPRSTVXY]{1}\d{1}[A-Z]{1} *\d{1}[A-Z]{1}\d{1}$)`)
var str = `19422
19422-1359
H2L 2G2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}