// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ticky: ([A-Z]*): ([\w ]*) \[([#0-9]*)\] \(([\w]*)\)").unwrap();
let string = "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}