using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(From:[^<\n\r]*<[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-.]+>)\n(Sent:[\r\s](Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday),[\r\s\S]*(AM|PM))\n(To:[\s]*[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-.]+)\n(Cc:[^\r\n]*[\r\n])?(Subject:[\s]*[^\n\r]*[\n\r])";
string input = @"asdasd
From: kunal with love <kunal.singh@sprinklr.com>
From: Kunal Singh <kunal.singh@sprinklr.com>
Sent: Wednesday, February 28, 2018 4:38 PM
To: kevinroberts192@outlook.com
Cc: Arjit Srivastava
Subject: fwd with cc and bcc
cc and bcc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}