import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+:[0-9]+, 80:[0-9]+, 443:[0-9]+(, [0-9]+:[0-9]+)+,$";
final String string = "The following lines should be matched -\n\n"
+ "0:0, 80:3, 443:0, 8883:0, 9000:0, 9001:0,\n"
+ "0:0, 80:0, 443:1, 8883:0, 9000:0, 9001:0,\n"
+ "0:0, 80:0, 443:0, 8883:0, 9000:0, 9001:0,\n"
+ "0:0, 80:3, 443:1, 8883:0, 9000:0, 9001:0,\n\n"
+ "and the ones below should not be matched -\n\n"
+ "0:0, 443:0, 8883:0, 9000:0, 9001:0,\n"
+ "0:0, 80:0, 8883:0, 9000:0, 9001:0,\n"
+ "0:0, 8883:0, 9000:0, 9001:0,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}