$re = '/([A-Z])\1\1(?<![A-Z]{4})[a-z]([A-Z])\2\2(?![A-Z])/';
$str = 'bcAc BDBGFeQFFJaaBx BBBcDDD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);