$re = '/((?:
[^(),]+ |
( \(
(?: [^()]+ | (?2) )*
\) )
)+)
(?: ,\s* | $) /x';
$str = '$n(bar,foo), (bar),a.*$n(f04((?!z).)*)b,
hello$n(((((((abcdef)))))))world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);