# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x)\n"
r"(?(DEFINE)(?<a>[a-zA-Z]))\n"
r"\b(?=(?&a){2})\n"
r"((?&a))\n"
r"(?>\n"
r" (?>((?&a))|\b)\n"
r" (?=\n"
r" (?&a)*+[^.]+\n"
r" (\n"
r" (?(3)\3|\b)\n"
r" (?(4)\4|\2\b)\n"
r" )\n"
r" )\n"
r")++\b[^.]+\b\4")
test_str = ("From Mars: come the 'sraM,a deadly species that hunts humans. It hunts from nighttime til sunrise (when it's lit) using radar to peek for our faint electrical output. Its head, shaped like a pot top, can emit a \"hypersonic\" pulse - in short time. Ironically, when faced vs humans, its pot top head is weak against decaf coffee which will keep it at bay. Oh, and beware on every third moon it gets no sleep.\n\n"
"We should also tttttttttttest tsett, aabcdefg another aa, and fina,lly this. None of these should match.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.