re = /^([^\s]+)\s([^\s]+)\s([^\s]+)\s([^\s]+)\s+(?<server>[^\s]+)\s+\*(?<task>[^\s]+\:)\s+([^\s]+)\s+([^\s]+)\s+([^\s]+)\s+\%(?<status>[^\s]+)\s+(?<task1>[^\s]+)\s+(?<action>[^\s]+\')\s+\w+\s+\w+\:\s+(?<src_mac>[^\s]+)\s+\w+\s+\w+\:\s+(?<dest_mac>[^\s]+)\s+\w+\s\'\w+\'\s+(?<tast2>)\w+\s+\'(?<action2>[^\s]+)\s+\w+\s+\'\w+\'\s+\w+\s+\w+\s+\'(?<timesec>[^\s]+)\s+\w+/
str = 'Feb 27 16:41:39 10.128.5.5 tc-cl-wlc01: *apfReceiveTask: Feb 27 16:41:38.944: %APF-3-NO_FRAMED_IP_ADDRESS: [PA]apf_radius.c:2456 \'AcctStop\' clt MAC: 14:32:d1:c9:43:58 AP MAC: c0:25:5c:60:ab:f0 Role \'Local\' PemState \'START\' SSID \'CPS\' Connected for \'126\' secs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end