package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:lower:]]?`)
var str = `_AaBbCcDdEeFfGg12345!@#$% \t`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}