import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?# var )\n"
+ " (?<var>[a-zA-Z_\\x7f-\\xff][\\w\\x7f-\\xff]*)\n"
+ " (?# val )\n"
+ " (?<val>(?&call)|(?&str)|(?&num)|(?&bool))\n"
+ " (?<call>\\$\\{CALL\\s+[a-zA-Z_\\x7f-\\xff][\\w\\x7f-\\xff]*\\s*\\})\n"
+ " (?<str>\"[^\"]*\"|'[^']*')\n"
+ " (?<num>\\d+)\n"
+ " (?<bool>(?i)(?:false|true)(?-i))\n"
+ ")\n"
+ "((?(?=no(?8)\\S)no|yes))\n"
+ "(\\$\\{(?P<type>VAR)\\s+((?&var))\\s*\\=\\s*((?&val))\\s*\\})(\\S)?";
final String string = "\n\n"
+ " ${VAR foo=\"What\"}x\n\n"
+ " ${VAR foo=\"What\"} \n\n"
+ " yes${VAR foo=\"What\"}\n\n"
+ " no${VAR foo=\"What\"}x\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}