#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((.)\2+)|(.)"
Local $sString = "aaa" & @CRLF & _
"abc" & @CRLF & _
"yahoo" & @CRLF & _
"opinion" & @CRLF & _
"aaaaaabc"
Local $sSubst = "$1$3$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)