package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\\?\w+(?:\\{1}\w+)+):(\w*+)(#.*)?()$`)
var str = `Class\Name`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}