$re = '/^(7)(.{7})$/m';
$str = '71234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);