$re = '/(?!(^ignoreme$)|(^ignoreme2$))/m';
$str = 'ignoreme
ignoreme2
ignoremex
ignorem
gnoreme
ignoreme22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);