using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"begin((?!word1|word2).)*end";
string input = @"begin word2 end
begin bla end
begin word1 end
begin bla end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}