using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*__\K.+";
string input = @"my__field__name__options";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}