re = /^(?:([. ])\d{3}(\1\d{3})*)?$/m
str = '.123.123.123
123 123 123
.123 123 123.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end