$re = '~\d{4}_\d_\d{4}$~m';
$str = 'first_name_5965_1_5969
email_5961_1_5962';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);