import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^XXX-\\d{4}-(?![XYT])[A-Z]{4}$";
final String string = "XXX-0000-XBCD\n"
+ "XXX-0000-AXCD\n"
+ "XXX-0000-ABXD\n"
+ "XXX-0000-ABCX\n"
+ "XXX-0000-XXCD\n"
+ "XXX-0000-XBXD\n"
+ "XXX-0000-XBCX\n"
+ "XXX-0000-AXXD\n"
+ "XXX-0000-AXCX\n"
+ "XXX-0000-ABXX\n"
+ "XXX-0000-XXXX\n"
+ "XXX-0000-AB1D\n"
+ "XXX-0000-A%CD\n"
+ "XXX-0000-ABCDE\n"
+ "XXX-0000-ABCDX\n"
+ "AXXX-0000-ABCD\n"
+ "XXX-A0000-ABCD\n"
+ "XXX-0000-ABCD\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}