# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"XXX-\d{4}-(?!.*?[XYT])[A-Z]{4}"
test_str = ("XXX-0000-XBCD\n"
"XXX-0000-AXCD\n"
"XXX-0000-ABXD\n"
"XXX-0000-ABCX\n"
"XXX-0000-XXCD\n"
"XXX-0000-XBXD\n"
"XXX-0000-XBCX\n"
"XXX-0000-AXXD\n"
"XXX-0000-AXCX\n"
"XXX-0000-ABXX\n"
"XXX-0000-XXXX\n"
"XXX-0000-AB1D\n"
"XXX-0000-A%CD\n"
"XXX-0000-ABCDE\n"
"XXX-0000-ABCDX\n"
"AXXX-0000-ABCD\n"
"XXX-A0000-ABCD\n"
"XXX-0000-ABCD\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.